summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <DaveDavenport@users.noreply.github.com>2017-05-15 22:46:33 +0200
committerGitHub <noreply@github.com>2017-05-15 22:46:33 +0200
commit494550d38d572801ba3924611b09c7ca2b20610a (patch)
treedf744a40f2bcaee4ba155faf4113b42089494500 /Makefile.am
parente397c346da38f71c8b8f6e5e4cf57f7ee01b2404 (diff)
[ThemeParser] Add CSS color names support
* [ThemeParser] Add css color names * Add CSS color support (WIP) * Parse color names in the lexer. * Add test for css color names * Indent and fix ordering
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9411806d..e76fc934 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,7 @@ SOURCES=\
source/widgets/scrollbar.c\
source/xrmoptions.c\
source/x11-helper.c\
+ source/css-colors.c\
source/dialogs/run.c\
source/dialogs/ssh.c\
source/dialogs/drun.c\
@@ -82,6 +83,7 @@ SOURCES=\
include/timings.h\
include/history.h\
include/theme.h\
+ include/css-colors.h\
include/default-theme.h\
include/widgets/box.h\
include/widgets/container.h\
@@ -319,6 +321,7 @@ widget_test_SOURCES=\
source/widgets/widget.c\
source/widgets/textbox.c\
source/theme.c\
+ source/css-colors.c\
source/helper.c\
source/x11-helper.c\
config/config.c\
@@ -334,7 +337,9 @@ box_test_SOURCES=\
lexer/theme-parser.y\
lexer/theme-lexer.l\
source/theme.c\
+ source/css-colors.c\
include/theme.h\
+ include/css-colors.h\
test/box-test.c
scrollbar_test_LDADD=$(textbox_test_LDADD)
@@ -345,7 +350,9 @@ scrollbar_test_SOURCES=\
lexer/theme-parser.y\
lexer/theme-lexer.l\
source/theme.c\
+ source/css-colors.c\
include/theme.h\
+ include/css-colors.h\
test/scrollbar-test.c
textbox_test_SOURCES=\
@@ -354,6 +361,7 @@ textbox_test_SOURCES=\
lexer/theme-parser.y\
lexer/theme-lexer.l\
source/theme.c\
+ source/css-colors.c\
source/helper.c\
source/x11-helper.c\
config/config.c\
@@ -382,6 +390,7 @@ theme_parser_test_SOURCES=\
include/helper.h\
include/helper-theme.h\
include/theme.h\
+ include/css-colors.h\
include/xrmoptions.h\
source/xrmoptions.c\
source/x11-helper.c\
@@ -389,6 +398,7 @@ theme_parser_test_SOURCES=\
lexer/theme-parser.c\
lexer/theme-parser.h\
source/theme.c\
+ source/css-colors.c\
test/theme-parser-test.c
endif