summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-10-27 15:28:11 +0200
committerDave Davenport <qball@gmpclient.org>2016-10-27 15:28:11 +0200
commitf0d2a06268d6c0eb998a771a5a55577d44acac8a (patch)
tree220c41a887f1218e75fd3f6cb79c38da06ec32aa /Makefile.am
parentfb459e16606da7e53d46661b151869ad01e242e6 (diff)
Add some themes to be installed, add theme-selector script thingy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5698e5f6..d41270fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,9 @@ include $(top_srcdir)/libgwater-xcb-nolibtool.mk
##
bin_PROGRAMS=rofi
-dist_bin_SCRIPTS=script/rofi-sensible-terminal
+dist_bin_SCRIPTS=\
+ script/rofi-sensible-terminal\
+ script/rofi-theme-selector
nodist_rofi_SOURCES=\
$(top_builddir)/gitconfig.h
@@ -119,6 +121,21 @@ markdown_FILES=\
README.html: README.md
$(md_verbose) markdown $< > $@
+
+###
+# Themes
+###
+themedir=$(pkgdatadir)/themes/
+theme_DATA=\
+ themes/android_notification.theme\
+ themes/Arc.theme\
+ themes/blor.theme\
+ themes/blue.theme\
+ themes/c64.theme\
+ themes/glue_pro_blue.theme\
+ themes/solarized.theme\
+ themes/solarized_alternate.theme
+
##
# Extra DIST
##
@@ -130,8 +147,8 @@ EXTRA_DIST=\
AUTHORS\
doc/rofi.doxy.in\
script/get_git_rev.sh\
+ $(theme_DATA)\
Changelog
-
##
# Indent
##