summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-01-01 16:32:01 +0100
committerDave Davenport <qball@gmpclient.org>2017-01-01 16:32:01 +0100
commitd20587da543dfa0f67474a5070a5eb3620deb2e4 (patch)
tree48f0d0ddeb9fa268ca9c05ef6e66d2e29e82731f /Makefile.am
parent7d16d1a55269e58e3d9068685524a220cec360e6 (diff)
Fix? tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4fd6ecc..93e546fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,7 +96,8 @@ rofi_CFLAGS=\
-I$(top_srcdir)/config/\
-I$(top_builddir)/\
-Werror=missing-prototypes\
- -DSYSCONFDIR=\"$(sysconfdir)\"
+ -DSYSCONFDIR=\"$(sysconfdir)\"\
+ -DTHEME_CONVERTER
rofi_LDADD=\
$(glib_LIBS)\
@@ -268,6 +269,13 @@ widget_test_LDADD=$(textbox_test_LDADD)
widget_test_CFLAGS=$(textbox_test_CFLAGS)
widget_test_SOURCES=\
source/widgets/widget.c\
+ source/widgets/textbox.c\
+ source/theme.c\
+ source/helper.c\
+ source/x11-helper.c\
+ config/config.c\
+ lexer/theme-parser.y\
+ lexer/theme-lexer.l\
test/widget-test.c
box_test_LDADD=$(textbox_test_LDADD)
@@ -298,6 +306,8 @@ textbox_test_SOURCES=\
lexer/theme-parser.y\
lexer/theme-lexer.l\
source/theme.c\
+ source/helper.c\
+ source/x11-helper.c\
config/config.c\
include/keyb.h\
include/rofi.h\