summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-06-01 07:57:04 +0200
committerDave Davenport <qball@gmpclient.org>2016-06-01 07:57:04 +0200
commitc0954764193fd4113347bb66f847a9c9f45366e6 (patch)
tree535347509852cfd79eea3da3ac4c7cf5794dcb88 /Makefile.am
parent01ce909c9773ba2d623e704deeddcdabc18f0498 (diff)
Add extra test for widget.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f7834ef..f50c0240 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -142,7 +142,7 @@ update-manpage: $(top_srcdir)/doc/rofi-manpage.markdown
##
# Rofi test program
##
-check_PROGRAMS=history_test textbox_test helper_test helper_expand helper_config_cmdline_parser
+check_PROGRAMS=history_test textbox_test helper_test helper_expand helper_config_cmdline_parser widget_test
history_test_CFLAGS=\
$(AM_CFLAGS)\
@@ -188,6 +188,11 @@ textbox_test_LDADD=\
$(cairo_LIBS)\
$(libsn_LIBS)
+widget_test_LDADD=$(textbox_test_LDADD)
+widget_test_CFLAGS=$(textbox_test_CFLAGS)
+widget_test_SOURCES=\
+ source/widget.c\
+ test/widget-test.c
textbox_test_SOURCES=\
source/widget.c\
source/textbox.c\
@@ -273,7 +278,8 @@ TESTS=\
history_test\
helper_test\
helper_expand\
- helper_config_cmdline_parser
+ helper_config_cmdline_parser\
+ widget_test
.PHONY: test-x
test-x: $(bin_PROGRAMS) textbox_test