summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-10-24 17:48:04 +0200
committerDave Davenport <qball@gmpclient.org>2016-10-24 17:48:04 +0200
commitb19ab62e1796a0570e6943e04aed904970f9e6e8 (patch)
tree0762977528c66f44489567e8535298bb49352ec3 /Makefile.am
parent5f1cd754923dc409e38e39ba5a9809be6e75b2c9 (diff)
add scrollbar test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b63b1b15..5698e5f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,7 +152,8 @@ check_PROGRAMS=\
helper_tokenize\
helper_config_cmdline_parser\
widget_test\
- box_test
+ box_test\
+ scrollbar_test
history_test_CFLAGS=\
@@ -237,6 +238,14 @@ box_test_SOURCES=\
source/widgets/widget.c\
source/widgets/box.c\
test/box-test.c
+
+scrollbar_test_LDADD=$(textbox_test_LDADD)
+scrollbar_test_CFLAGS=$(textbox_test_CFLAGS)
+scrollbar_test_SOURCES=\
+ source/widgets/widget.c\
+ source/widgets/scrollbar.c\
+ test/scrollbar-test.c
+
textbox_test_SOURCES=\
source/widgets/widget.c\
source/widgets/textbox.c\
@@ -323,7 +332,8 @@ TESTS=\
helper_config_cmdline_parser\
textbox_test\
widget_test\
- box_test
+ box_test\
+ scrollbar_test
.PHONY: test-x
test-x: $(bin_PROGRAMS)