summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-03-21 17:16:45 +0100
committerDave Davenport <qball@gmpclient.org>2016-03-21 17:16:45 +0100
commit8914fbf2df7c78194ce9d45d12c695d0c8314eb0 (patch)
treeb15eea60910d5bc205ca3f572f7acc76c37aa600 /Makefile.am
parent1e3294fa682a632cf72ff4c2f96c9c3216fc8e3e (diff)
Split test in 2.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c25e4b1..1136a6a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,7 +139,7 @@ update-manpage: $(top_srcdir)/doc/rofi-manpage.markdown
##
# Rofi test program
##
-check_PROGRAMS=rofi_test textbox_test helper_test
+check_PROGRAMS=rofi_test textbox_test helper_test helper_expand
rofi_test_CFLAGS=\
$(AM_CFLAGS)\
@@ -235,9 +235,26 @@ helper_test_LDADD=\
$(libsn_LIBS)\
$(cairo_LIBS)
+helper_expand_SOURCES=\
+ config/config.c\
+ include/rofi.h\
+ include/mode.h\
+ include/mode-private.h\
+ source/helper.c\
+ include/helper.h\
+ include/xrmoptions.h\
+ source/xrmoptions.c\
+ source/x11-helper.c\
+ test/helper-expand.c
+
+helper_expand_CFLAGS=${helper_test_CFLAGS}
+
+helper_expand_LDADD=${helper_test_LDADD}
+
TESTS=\
rofi_test\
- helper_test
+ helper_test\
+ helper_expand
.PHONY: test-x
test-x: $(bin_PROGRAMS) textbox_test