summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-02-28 01:21:22 +0100
committerDave Davenport <qball@gmpclient.org>2016-02-28 01:21:22 +0100
commit6d0d6d9eb2c2e75ec26d442eb0768772c6f1964e (patch)
treef6caabb7bd0201f5a002eb6d778a9ac06df16833 /Makefile.am
parent93cb9ee7eb81172b6258dfdae998cefc2b78f0cb (diff)
Tests.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index b14f18f9..880c511d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -189,10 +189,6 @@ textbox_test_SOURCES=\
source/widget.c\
source/textbox.c\
config/config.c\
- source/keyb.c\
- source/x11-helper.c\
- source/xrmoptions.c\
- source/helper.c\
include/keyb.h\
include/rofi.h\
include/mode.h\
@@ -201,7 +197,6 @@ textbox_test_SOURCES=\
include/widget.h\
include/textbox.h\
include/widget.h\
- include/x11-helper.h\
include/xrmoptions.h\
include/helper.h\
test/textbox-test.c
@@ -215,6 +210,7 @@ helper_test_SOURCES=\
include/helper.h\
include/xrmoptions.h\
source/xrmoptions.c\
+ source/x11-helper.c\
test/helper-test.c
helper_test_CFLAGS=\
@@ -223,6 +219,7 @@ helper_test_CFLAGS=\
$(pango_CFLAGS)\
$(x11_CFLAGS)\
$(xinerama_CFLAGS)\
+ $(GW_XCB_CFLAGS)\
$(cairo_CFLAGS)\
-I$(top_srcdir)/include/\
-I$(top_srcdir)/config/\
@@ -232,6 +229,7 @@ helper_test_LDADD=\
$(glib_LIBS)\
$(pango_LIBS)\
$(x11_LIBS)\
+ $(GW_XCB_LIBS)\
$(xinerama_LIBS)\
$(cairo_LIBS)