summaryrefslogtreecommitdiffstats
path: root/ignore/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ignore/Cargo.toml')
-rw-r--r--ignore/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/ignore/Cargo.toml b/ignore/Cargo.toml
new file mode 100644
index 00000000..520f9cf4
--- /dev/null
+++ b/ignore/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+name = "ignore"
+version = "0.1.0" #:version
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = """
+A fast library for efficiently matching ignore files such as `.gitignore`
+against file paths.
+"""
+documentation = "https://docs.rs/ignore"
+homepage = "https://github.com/BurntSushi/ripgrep/tree/master/ignore"
+repository = "https://github.com/BurntSushi/ripgrep/tree/master/ignore"
+readme = "README.md"
+keywords = ["glob", "ignore", "gitignore", "pattern", "file"]
+license = "Unlicense/MIT"
+
+[lib]
+name = "ignore"
+bench = false
+
+[dependencies]
+globset = { version = "0.1.0", path = "../globset" }
+lazy_static = "0.2"
+log = "0.3"
+memchr = "0.1"
+regex = "0.1.77"
+thread_local = "0.2.7"
+walkdir = "1"
+
+[dev-dependencies]
+tempdir = "0.3.5"
+
+[features]
+simd-accel = ["globset/simd-accel"]
+
+[profile.release]
+debug = true