summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7a40ae5c..a7ccd5bd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -91,9 +91,13 @@ assets = [
["FAQ.md", "usr/share/doc/ripgrep/FAQ", "644"],
# The man page is automatically generated by ripgrep's build process, so
# this file isn't actually commited. Instead, to create a dpkg, either
- # create a deployment directory and copy the man page to it, or use the
+ # create a deployment/deb directory and copy the man page to it, or use the
# 'ci/build_deb.sh' script.
- ["deployment/rg.1", "usr/share/man/man1/rg.1", "644"],
+ ["deployment/deb/rg.1", "usr/share/man/man1/rg.1", "644"],
+ # Similarly for shell completions.
+ ["deployment/deb/rg.bash", "usr/share/bash-completion/completions/rg", "644"],
+ ["deployment/deb/rg.fish", "usr/share/fish/completions/rg.fish", "644"],
+ ["deployment/deb/_rg", "usr/share/zsh/vendor-completions/", "644"],
]
extended-description = """\
ripgrep (rg) recursively searches your current directory for a regex pattern.