summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 457f1d83..90c6ae85 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -74,6 +74,13 @@ pcre2 = ["grep/pcre2"]
[profile.release]
debug = 1
+# This is the main way to strip binaries in the deb package created by
+# 'cargo deb'. For other release binaries, we (currently) call 'strip'
+# explicitly in the release process.
+[profile.deb]
+inherits = "release"
+debug = false
+
[package.metadata.deb]
features = ["pcre2"]
section = "utils"