summaryrefslogtreecommitdiffstats
path: root/ignore/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2019-01-27 10:45:09 -0500
committerAndrew Gallant <jamslam@gmail.com>2019-01-27 12:11:52 -0500
commitf158a42a715fb6470aa2924182cbf8e1e0fd9448 (patch)
tree1a87cc84ad8f9851ecfe2edde77c6dd96eac8e25 /ignore/Cargo.toml
parent5724391d3956dbc68c005d4e6f8f8e4718a052bd (diff)
ignore: correctly detect hidden files on Windows
This commit fixes a bug where ripgrep only treated files beginning with a `.` as hidden. On Windows, we continue this tradition, but additionally check whether a file has the special Windows "hidden" attribute set. If so, we treat it as a hidden file. In order to make this work without an additional stat call, we had to rearrange some of the plumbing from the directory traverser. Fixes #1154
Diffstat (limited to 'ignore/Cargo.toml')
-rw-r--r--ignore/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/ignore/Cargo.toml b/ignore/Cargo.toml
index 0d4b4a7e..9d5e13d9 100644
--- a/ignore/Cargo.toml
+++ b/ignore/Cargo.toml
@@ -29,7 +29,7 @@ thread_local = "0.3.6"
walkdir = "2.2.7"
[target.'cfg(windows)'.dependencies.winapi-util]
-version = "0.1.1"
+version = "0.1.2"
[dev-dependencies]
tempfile = "3.0.5"