summaryrefslogtreecommitdiffstats
path: root/grep-searcher/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-04-29 09:29:52 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-08-20 07:10:19 -0400
commitd9ca5293569efb255608d3c601107bcfe7060f15 (patch)
tree7fd8611c333a2f7d703987de3a379ee8292013e2 /grep-searcher/Cargo.toml
parent0958837ee104985412f08e81b6f08df1e5291042 (diff)
libripgrep: initial commit introducing libripgrep
libripgrep is not any one library, but rather, a collection of libraries that roughly separate the following key distinct phases in a grep implementation: 1. Pattern matching (e.g., by a regex engine). 2. Searching a file using a pattern matcher. 3. Printing results. Ultimately, both (1) and (3) are defined by de-coupled interfaces, of which there may be multiple implementations. Namely, (1) is satisfied by the `Matcher` trait in the `grep-matcher` crate and (3) is satisfied by the `Sink` trait in the `grep2` crate. The searcher (2) ties everything together and finds results using a matcher and reports those results using a `Sink` implementation. Closes #162
Diffstat (limited to 'grep-searcher/Cargo.toml')
-rw-r--r--grep-searcher/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/grep-searcher/Cargo.toml b/grep-searcher/Cargo.toml
new file mode 100644
index 00000000..9fad2030
--- /dev/null
+++ b/grep-searcher/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "grep-searcher"
+version = "0.0.1" #:version
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = """
+Fast line oriented regex searching as a library.
+"""
+documentation = "https://docs.rs/grep-searcher"
+homepage = "https://github.com/BurntSushi/ripgrep"
+repository = "https://github.com/BurntSushi/ripgrep"
+readme = "README.md"
+keywords = ["regex", "grep", "egrep", "search", "pattern"]
+license = "Unlicense/MIT"
+
+[dependencies]
+bytecount = "0.3.1"
+encoding_rs = "0.8"
+encoding_rs_io = "0.1.2"
+grep-matcher = { version = "0.0.1", path = "../grep-matcher" }
+log = "0.4"
+memchr = "2"
+memmap = "0.6"
+
+[dev-dependencies]
+grep-regex = { version = "0.0.1", path = "../grep-regex" }
+regex = "1"
+
+[features]
+avx-accel = [
+ "bytecount/avx-accel",
+]
+simd-accel = [
+ "bytecount/simd-accel",
+ "encoding_rs/simd-accel",
+]