summaryrefslogtreecommitdiffstats
path: root/grep-cli/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2019-04-04 15:15:48 -0400
committerAndrew Gallant <jamslam@gmail.com>2019-04-05 20:42:33 -0400
commitb1c064d5afba77de0ded6bc35b0dfb61d8e111f7 (patch)
tree855c8b454b380887037e669a5dc95eeec3043e2d /grep-cli/Cargo.toml
parent26a83c6301ad239b361f17f711644cb006dc7031 (diff)
cli: use bstr
This uses bstr in the unescaping logic. This lets us remove some platform specific code, and also lets us remove a hacked UTF-8 decoder on raw bytes.
Diffstat (limited to 'grep-cli/Cargo.toml')
-rw-r--r--grep-cli/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/grep-cli/Cargo.toml b/grep-cli/Cargo.toml
index 29e15b28..f143e401 100644
--- a/grep-cli/Cargo.toml
+++ b/grep-cli/Cargo.toml
@@ -14,6 +14,7 @@ license = "Unlicense/MIT"
[dependencies]
atty = "0.2.11"
+bstr = "0.1.2"
globset = { version = "0.4.2", path = "../globset" }
lazy_static = "1.1.0"
log = "0.4.5"