summaryrefslogtreecommitdiffstats
path: root/crates/regex/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2020-02-17 18:19:19 -0500
committerAndrew Gallant <jamslam@gmail.com>2020-02-17 19:24:53 -0500
commitfdd8510fdda6109c562e479c718d42c8ecc26263 (patch)
treef510c952f62d0ebdcbf689000b2d7aebc90d5ba7 /crates/regex/Cargo.toml
parent0bc4f0447b05468f043e06278a3ca2b1c5646f9b (diff)
repo: move all source code in crates directory
The top-level listing was just getting a bit too long for my taste. So put all of the code in one directory and shrink the large top-level mess to a small top-level mess. NOTE: This commit only contains renames. The subsequent commit will actually make ripgrep build again. We do it this way with the naive hope that this will make it easier for git history to track the renames. Sigh.
Diffstat (limited to 'crates/regex/Cargo.toml')
-rw-r--r--crates/regex/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/crates/regex/Cargo.toml b/crates/regex/Cargo.toml
new file mode 100644
index 00000000..a1dbb9f9
--- /dev/null
+++ b/crates/regex/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "grep-regex"
+version = "0.1.5" #:version
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = """
+Use Rust's regex library with the 'grep' crate.
+"""
+documentation = "https://docs.rs/grep-regex"
+homepage = "https://github.com/BurntSushi/ripgrep"
+repository = "https://github.com/BurntSushi/ripgrep"
+readme = "README.md"
+keywords = ["regex", "grep", "search", "pattern", "line"]
+license = "Unlicense/MIT"
+
+[dependencies]
+aho-corasick = "0.7.3"
+bstr = "0.2.10"
+grep-matcher = { version = "0.1.2", path = "../grep-matcher" }
+log = "0.4.5"
+regex = "1.1"
+regex-syntax = "0.6.5"
+thread_local = "1"