summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-03-10 14:02:06 -0500
committerAndrew Gallant <jamslam@gmail.com>2018-03-12 23:21:42 -0400
commit1f70e9187ceca65e7196f65e8cad1cba65efb47c (patch)
tree3b7b64fc69812a9bea2c907a1668657115d2e797 /Cargo.toml
parent7120f3225862f6c718a37a8616debaebd8c3d459 (diff)
deps: update regex crate
This update brings with it a new feature of the regex crate which will now use SIMD optimizations automatically at runtime with no necessary compile time flags. All that's needed is to enable the `unstable` feature. Other crates, such as bytecount and encoding_rs, are still using the old-style SIMD support, so we leave the simd-accel and avx-accel features. However, the binaries we distribute on Github no longer have those features enabled, which makes them truly portable. Fixes #135
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 51108f20..7acec26c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,7 +45,7 @@ log = "0.4"
memchr = "2"
memmap = "0.6"
num_cpus = "1"
-regex = "0.2.4"
+regex = "0.2.9"
same-file = "1"
termcolor = { version = "0.3.4", path = "termcolor" }
@@ -67,12 +67,13 @@ default-features = false
features = ["suggestions", "color"]
[features]
-avx-accel = ["bytecount/avx-accel"]
+avx-accel = ["bytecount/avx-accel", "regex/unstable"]
simd-accel = [
"bytecount/simd-accel",
- "regex/simd-accel",
"encoding_rs/simd-accel",
+ "regex/unstable",
]
+unstable = ["regex/unstable"]
[profile.release]
debug = true