summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2017-01-15 16:32:30 -0500
committerAndrew Gallant <jamslam@gmail.com>2017-01-15 16:32:30 -0500
commitf5a2d022ecd16dfe67ea829267e9220136f20167 (patch)
tree0d0683b39a2f352b1dee63bed4216c486ed28b20 /Cargo.toml
parentb1d1cd2366ba8d3e40a312ba79ff7078a97165f5 (diff)
Replace internal atty module with atty crate.
This removes all use of explicit unsafe in ripgrep proper except for one: accessing the contents of a memory map. (Which may never go away.)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b65e1368..da1c9d2b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,6 +25,7 @@ name = "integration"
path = "tests/tests.rs"
[dependencies]
+atty = "0.2.2"
bytecount = "0.1.4"
clap = "2.19.0"
env_logger = { version = "0.3", default-features = false }