summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2016-12-24 12:53:09 -0500
committerAndrew Gallant <jamslam@gmail.com>2016-12-24 12:53:09 -0500
commitde5cb7d22e00c18dfce082a68b0cf45924b56e7f (patch)
tree74dcc51d61e2b71bea02265d365504f17bcd39e9 /Cargo.toml
parent7a682f465e74d31ade4cb96c8d32110d33deebd7 (diff)
Remove special ^C handling.
This means that ripgrep will no longer try to reset your colors in your terminal if you kill it while searching. This could result in messing up the colors in your terminal, and the fix is to simply run some other command that resets them for you. For example: $ echo -ne "\033[0m" The reason why the ^C handling was removed is because it is irrevocably broken on Windows and is impossible to do correctly and efficiently in ANSI terminals. Fixes #281
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a2bd2c57..3a24d53a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,7 +27,6 @@ path = "tests/tests.rs"
[dependencies]
bytecount = "0.1.4"
clap = "2.19.0"
-ctrlc = "2.0"
env_logger = "0.3"
grep = { version = "0.1.4", path = "grep" }
ignore = { version = "0.1.5", path = "ignore" }