summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2016-08-28 20:18:34 -0400
committerAndrew Gallant <jamslam@gmail.com>2016-08-28 20:18:34 -0400
commitc809679cf2d8293deae98b75dc728ede4d4894cd (patch)
tree84cd3e3d03b7a19172b18f2802fbdf675faca0f3 /Cargo.toml
parent1c8379f55a6f07df0d28dc294ff80ad56f06459f (diff)
Lots of improvements. Most notably, removal of memory maps for searching.
Memory maps appear to degrade quite a bit in the presence of multithreading. Also, switch to lock free data structures for synchronization. Give each worker an input and output buffer which require no synchronization.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9a19a660..e93f412b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,9 +27,11 @@ log = "0.3"
memchr = "0.1"
memmap = "0.2"
num_cpus = "1"
+parking_lot = "0.3"
regex = { version = "0.1", path = "/home/andrew/rust/regex" }
regex-syntax = { version = "0.3.1", path = "/home/andrew/rust/regex/regex-syntax" }
rustc-serialize = "0.3"
+thread_local = "0.2"
walkdir = "0.1"
[features]
@@ -41,3 +43,4 @@ lazy_static = "0.2"
[profile.release]
debug = true
+panic = "abort"