summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2016-08-25 21:44:37 -0400
committerAndrew Gallant <jamslam@gmail.com>2016-08-25 21:44:37 -0400
commitb55ecf34c713392b012dd652fbbd11d7e0126d97 (patch)
tree323cc2f2cbf8f58cfee742f4307094df6a13a753 /Cargo.toml
parent957f90c8988779fae8c466e2697dbc2ae542f0ff (diff)
globbing by regex
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9f36d765..d4d59f63 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,14 +13,25 @@ readme = "README.md"
keywords = ["regex", "grep", "egrep", "search", "pattern"]
license = "Unlicense/MIT"
+[[bin]]
+bench = false
+path = "src/main.rs"
+name = "xrep"
+
[dependencies]
docopt = "0.6"
grep = { version = "0.1", path = "grep" }
memchr = "0.1"
memmap = "0.2"
+num_cpus = "1"
regex = { version = "0.1", path = "/home/andrew/rust/regex" }
regex-syntax = { version = "0.3.1", path = "/home/andrew/rust/regex/regex-syntax" }
rustc-serialize = "0.3"
+walkdir = "0.1"
+
+[dev-dependencies]
+glob = "0.2"
+lazy_static = "0.2"
[profile.release]
debug = true