summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2016-08-27 01:01:06 -0400
committerAndrew Gallant <jamslam@gmail.com>2016-08-27 01:01:06 -0400
commit065c44998092906746f6585090bafbf36d98342b (patch)
treeaff9d512fd19767309fd0bad6b18a674ec84b00c /Cargo.toml
parentb55ecf34c713392b012dd652fbbd11d7e0126d97 (diff)
File path filtering works and is pretty fast.
I'm pretty disappointed by the performance of regex sets. They are apparently spending a lot of their time in construction of the DFA, which probably means that the DFA is just too big. It turns out that it's actually faster to build an *additional* normal regex with the alternation of every glob and use it as a first-pass filter over every file path. If there's a match, only then do we try the more expensive RegexSet.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d4d59f63..15b268c9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,6 +29,9 @@ regex-syntax = { version = "0.3.1", path = "/home/andrew/rust/regex/regex-syntax
rustc-serialize = "0.3"
walkdir = "0.1"
+[features]
+simd-accel = ["regex/simd-accel"]
+
[dev-dependencies]
glob = "0.2"
lazy_static = "0.2"