summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-07-17 20:24:36 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-07-17 20:27:04 -0400
commit06b66efd59b83012d34a3c11e72b4c4901ae756a (patch)
tree9c1e75ed1257f22ea53ade9a89f230647112dd68 /Cargo.toml
parent7e5a59027638952ae55a1cc3d9d3b2ce7d69be98 (diff)
deps: get rid of unstable feature
This was introduced as a temporary measure for dealing with the regex crate's unstable feature, but it was never included in a release of ripgrep. Thus, we remove it. The regex crate will now automatically enable SIMD optimizations when available.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 15653fdb..04fade19 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -69,13 +69,13 @@ default-features = false
features = ["suggestions", "color"]
[features]
-avx-accel = ["bytecount/avx-accel", "regex/unstable"]
+avx-accel = [
+ "bytecount/avx-accel",
+]
simd-accel = [
"bytecount/simd-accel",
"encoding_rs/simd-accel",
- "regex/unstable",
]
-unstable = ["regex/unstable"]
[profile.release]
debug = true