summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-08-21 21:26:18 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-08-21 23:05:52 -0400
commit5c80e4adb69c618e458cfc70a8502a497604825c (patch)
treeb67b9781845888a61693cd4db7fb079e3954b340 /Cargo.toml
parentfcd185303198f9a6c8026e0a632c84bacf36e779 (diff)
release: better support for binary Debian package
This commit beefs up the package metadata used by the 'cargo deb' tool to produce a binary dpkg. In particular, we now include ripgrep's man page. This commit includes a new script, 'ci/build_deb.sh', which will handle the build process for a dpkg, which has become a bit more nuanced than just running 'cargo deb'. We don't (yet) run this script in CI. Fixes #842
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 208a07b5..48296bdc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -84,3 +84,25 @@ pcre2 = ["grep/pcre2"]
[profile.release]
debug = 1
+
+[package.metadata.deb]
+features = ["pcre2"]
+assets = [
+ ["target/release/rg", "usr/bin/", "755"],
+ ["COPYING", "usr/share/doc/ripgrep/", "644"],
+ ["LICENSE-MIT", "usr/share/doc/ripgrep/", "644"],
+ ["UNLICENSE", "usr/share/doc/ripgrep/", "644"],
+ ["CHANGELOG.md", "usr/share/doc/ripgrep/CHANGELOG", "644"],
+ ["README.md", "usr/share/doc/ripgrep/README", "644"],
+ ["FAQ.md", "usr/share/doc/ripgrep/FAQ", "644"],
+ # The man page is automatically generated by ripgrep's build process, so
+ # this file isn't actually commited. Instead, to create a dpkg, either
+ # create a deployment directory and copy the man page to it, or use the
+ # 'ci/build_deb.sh' script.
+ ["deployment/rg.1", "usr/share/man/man1/rg.1", "644"],
+]
+extended-description = """\
+ripgrep (rg) recursively searches your current directory for a regex pattern.
+By default, ripgrep will respect your .gitignore and automatically skip hidden
+files/directories and binary files.
+"""