summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-08-03 17:26:22 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-08-20 07:10:19 -0400
commitbb110c1ebeeda452046830b3991f705f5759da92 (patch)
treecc2b0112a3ca9b8d05cf1e953553907d71564082 /Cargo.toml
parentd9ca5293569efb255608d3c601107bcfe7060f15 (diff)
ripgrep: migrate to libripgrep
This commit does the work to delete the old `grep` crate and effectively rewrite most of ripgrep core to use the new libripgrep crates. The new `grep` crate is now a facade that collects the various crates that make up libripgrep. The most complex part of ripgrep core is now arguably the translation between command line parameters and the library options, which is ultimately where we want to be.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 7 insertions, 19 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ec6ee1b5..74648607 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -35,7 +35,6 @@ path = "tests/tests.rs"
members = [
"globset",
"grep",
- "grep2",
"grep-matcher",
"grep-pcre2",
"grep-printer",
@@ -46,20 +45,15 @@ members = [
[dependencies]
atty = "0.2.11"
-bytecount = "0.3.2"
-encoding_rs = "0.8"
-encoding_rs_io = "0.1"
globset = { version = "0.4.0", path = "globset" }
-grep = { version = "0.1.8", path = "grep" }
+grep = { version = "0.2.0", path = "grep" }
ignore = { version = "0.4.0", path = "ignore" }
lazy_static = "1"
-libc = "0.2"
log = "0.4"
-memchr = "2"
-memmap = "0.6"
num_cpus = "1"
regex = "1"
same-file = "1"
+serde_json = "1"
termcolor = "1"
[dependencies.clap]
@@ -69,7 +63,7 @@ features = ["suggestions", "color"]
[target.'cfg(windows)'.dependencies.winapi]
version = "0.3"
-features = ["std", "winnt"]
+features = ["std", "fileapi", "winnt"]
[build-dependencies]
lazy_static = "1"
@@ -80,15 +74,9 @@ default-features = false
features = ["suggestions", "color"]
[features]
-avx-accel = [
- "bytecount/avx-accel",
- "grep2/avx-accel",
-]
-simd-accel = [
- "bytecount/simd-accel",
- "encoding_rs/simd-accel",
- "grep2/simd-accel",
-]
+avx-accel = ["grep/avx-accel"]
+simd-accel = ["grep/simd-accel"]
+pcre2 = ["grep/pcre2"]
[profile.release]
-debug = true
+debug = 1