summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-08-29 20:53:52 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-09-04 23:18:55 -0400
commit4846d63539690047fa58ec582d94bcba16da1c09 (patch)
tree61a2cf9de3d62ea6524659893ab9a2c7800c3286 /Cargo.toml
parent13c47530a6e685d2dee1953a64f055936e6a2ba8 (diff)
grep-cli: introduce new grep-cli crate
This commit moves a lot of "utility" code from ripgrep core into grep-cli. Any one of these things might not be worth creating a new crate, but combining everything together results in a fair number of a convenience routines that make up a decent sized crate. There is potentially more we could move into the crate, but much of what remains in ripgrep core is almost entirely dealing with the number of flags we support. In the course of doing moving things to the grep-cli crate, we clean up a lot of gunk and improve failure modes in a number of cases. In particular, we've fixed a bug where other processes could deadlock if they write too much to stderr. Fixes #990
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 1 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3ff769c6..0c489c46 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -35,6 +35,7 @@ path = "tests/tests.rs"
members = [
"globset",
"grep",
+ "grep-cli",
"grep-matcher",
"grep-pcre2",
"grep-printer",
@@ -44,15 +45,12 @@ members = [
]
[dependencies]
-atty = "0.2.11"
-globset = { version = "0.4.0", path = "globset" }
grep = { version = "0.2.0", path = "grep" }
ignore = { version = "0.4.0", path = "ignore" }
lazy_static = "1"
log = "0.4"
num_cpus = "1"
regex = "1"
-same-file = "1"
serde_json = "1"
termcolor = "1"
@@ -61,9 +59,6 @@ version = "2.32.0"
default-features = false
features = ["suggestions"]
-[target.'cfg(windows)'.dependencies.winapi-util]
-version = "0.1.1"
-
[build-dependencies]
lazy_static = "1"