summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-08-21 23:10:34 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-08-21 23:10:34 -0400
commit033ad2b8e4bca4ee7a9f01e5598e8b9a95b12b29 (patch)
tree4883d8bd16e8abe945a5e315f62f95ed111bed74 /Cargo.toml
parent098a8ee843eb4e110549a4b71923ab6a3f227d99 (diff)
deps: update clap
Update clap to the latest version. Also, drop the ansi_term dependency by disabling color output in clap's error messages.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 48296bdc..092f86d2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -57,9 +57,9 @@ serde_json = "1"
termcolor = "1"
[dependencies.clap]
-version = "2.29.4"
+version = "2.32.0"
default-features = false
-features = ["suggestions", "color"]
+features = ["suggestions"]
[target.'cfg(windows)'.dependencies.winapi]
version = "0.3"
@@ -69,9 +69,9 @@ features = ["std", "fileapi", "winnt"]
lazy_static = "1"
[build-dependencies.clap]
-version = "2.29.4"
+version = "2.32.0"
default-features = false
-features = ["suggestions", "color"]
+features = ["suggestions"]
[dev-dependencies]
serde = "1"