summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-09-07 13:14:31 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-09-07 14:00:22 -0400
commitd14f0b37d651b276fcd6a6938b0da918b17f3326 (patch)
treec06de798b5df66dd9bd51049444c02b93be8163f /Cargo.toml
parent3ddc3c040f7a0a6896738fc1d6dbe57fd75566b4 (diff)
deps: update versions for all crates
I don't think every change here is needed, but this ensures we're using the latest version of every direct dependency.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 12 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 92375b79..7a40ae5c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "ripgrep"
-version = "0.9.0" #:version
+version = "0.10.0" #:version
authors = ["Andrew Gallant <jamslam@gmail.com>"]
description = """
ripgrep is a line-oriented search tool that recursively searches your current
@@ -45,14 +45,14 @@ members = [
]
[dependencies]
-grep = { version = "0.2.1", path = "grep" }
-ignore = { version = "0.4.0", path = "ignore" }
-lazy_static = "1"
-log = "0.4"
-num_cpus = "1"
-regex = "1"
-serde_json = "1"
-termcolor = "1"
+grep = { version = "0.2.2", path = "grep" }
+ignore = { version = "0.4.4", path = "ignore" }
+lazy_static = "1.1.0"
+log = "0.4.5"
+num_cpus = "1.8.0"
+regex = "1.0.5"
+serde_json = "1.0.23"
+termcolor = "1.0.3"
[dependencies.clap]
version = "2.32.0"
@@ -60,7 +60,7 @@ default-features = false
features = ["suggestions"]
[build-dependencies]
-lazy_static = "1"
+lazy_static = "1.1.0"
[build-dependencies.clap]
version = "2.32.0"
@@ -68,8 +68,8 @@ default-features = false
features = ["suggestions"]
[dev-dependencies]
-serde = "1"
-serde_derive = "1"
+serde = "1.0.77"
+serde_derive = "1.0.77"
[features]
avx-accel = ["grep/avx-accel"]