summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2019-04-25 10:49:59 -0400
committerAndrew Gallant <jamslam@gmail.com>2019-04-25 11:12:14 -0400
commit5ce2d7351dba9c113318f4e43c041be7c25eaee4 (patch)
tree4b519245d76ade4ed9c2b1e8c1be7d10623f6b94 /Cargo.toml
parent9dcfd9a205914af1398d0c655956b2045f51b125 (diff)
ci: use cross for musl x86_64 builds
This is necessary because jemalloc + musl + Ubuntu 16.04 is apparently broken. Moreover, jemalloc doesn't support i686, so we accept the performance regression there. See also: https://github.com/gnzlbg/jemallocator/issues/124
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d8c68d75..7bd62d4f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -61,7 +61,7 @@ version = "2.32.0"
default-features = false
features = ["suggestions"]
-[target.'cfg(target_env = "musl")'.dependencies.jemallocator]
+[target.'cfg(all(target_env = "musl", target_pointer_width = "64"))'.dependencies.jemallocator]
version = "0.3.0"
[build-dependencies]