summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-04-21 11:38:45 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-04-21 12:01:11 -0400
commit58bd0c67da542cdeb369b3af90181b902c1c2c0d (patch)
tree3e392a5101e6c7dd209a35f25dfbbf8c4dd2d77b /Cargo.toml
parent1503b3175f2a07dbd405c113948c07f872e4e899 (diff)
deps: pin to atty 0.2.6
atty 0.2.7 (and 0.2.8) contain a regression in cygwin terminals that prevents basic use of ripgrep, and is also the cause of the Windows CI test failures. For now, we pin to 0.2.6, but a patch has been submitted upstream: https://github.com/softprops/atty/pull/25
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 750b597c..cc11bbe0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,7 +33,7 @@ path = "tests/tests.rs"
members = ["grep", "globset", "ignore", "termcolor", "wincolor"]
[dependencies]
-atty = "0.2.2"
+atty = "=0.2.6"
bytecount = "0.3.1"
encoding_rs = "0.7"
globset = { version = "0.3.0", path = "globset" }