summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-08-06 20:11:58 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-08-20 07:10:19 -0400
commiteb184d7711a3d01b2fd3a4281b193f39f7e9a2c5 (patch)
tree6531c55af7eae5670d224d347763ad1e3216e8b4 /Cargo.toml
parentbb110c1ebeeda452046830b3991f705f5759da92 (diff)
tests: re-tool integration tests
This basically rewrites every integration test. We reduce the amount of magic involved here in terms of which arguments are being passed to ripgrep processes. To make up for the boiler plate saved by the magic, we make the Dir (formerly WorkDir) type a bit nicer to use, along with a new TestCommand that wraps a std::process::Command. In exchange, we get tests that are easier to read and write. We also run every test with the `--pcre2` flag to make sure that works, when PCRE2 is available.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 74648607..208a07b5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -73,6 +73,10 @@ version = "2.29.4"
default-features = false
features = ["suggestions", "color"]
+[dev-dependencies]
+serde = "1"
+serde_derive = "1"
+
[features]
avx-accel = ["grep/avx-accel"]
simd-accel = ["grep/simd-accel"]