summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-04-29 09:29:52 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-08-20 07:10:19 -0400
commitd9ca5293569efb255608d3c601107bcfe7060f15 (patch)
tree7fd8611c333a2f7d703987de3a379ee8292013e2 /Cargo.toml
parent0958837ee104985412f08e81b6f08df1e5291042 (diff)
libripgrep: initial commit introducing libripgrep
libripgrep is not any one library, but rather, a collection of libraries that roughly separate the following key distinct phases in a grep implementation: 1. Pattern matching (e.g., by a regex engine). 2. Searching a file using a pattern matcher. 3. Printing results. Ultimately, both (1) and (3) are defined by de-coupled interfaces, of which there may be multiple implementations. Namely, (1) is satisfied by the `Matcher` trait in the `grep-matcher` crate and (3) is satisfied by the `Sink` trait in the `grep2` crate. The searcher (2) ties everything together and finds results using a matcher and reports those results using a `Sink` implementation. Closes #162
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 13 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ffa253f0..ec6ee1b5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,7 +32,17 @@ name = "integration"
path = "tests/tests.rs"
[workspace]
-members = ["grep", "globset", "ignore"]
+members = [
+ "globset",
+ "grep",
+ "grep2",
+ "grep-matcher",
+ "grep-pcre2",
+ "grep-printer",
+ "grep-regex",
+ "grep-searcher",
+ "ignore",
+]
[dependencies]
atty = "0.2.11"
@@ -72,10 +82,12 @@ features = ["suggestions", "color"]
[features]
avx-accel = [
"bytecount/avx-accel",
+ "grep2/avx-accel",
]
simd-accel = [
"bytecount/simd-accel",
"encoding_rs/simd-accel",
+ "grep2/simd-accel",
]
[profile.release]