summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-02-03 21:50:30 -0500
committerAndrew Gallant <jamslam@gmail.com>2018-02-04 10:40:20 -0500
commitc8e755f11f31b6da04329cdc7433747bba70150f (patch)
treec91a486846751aef5195d67d545932f606a93992 /Cargo.toml
parent68dac7c4b0743a6a08f89f915957e23b8e3f3441 (diff)
deps: remove vec-map feature from clap
This removes the vec-map feature from clap. clap's README claims that vec-map provides a small performance benefit, but I could observe any in ripgrep workloads. The benefit here is that it drops a dependency. Amazingly, this drops whole release build times for ripgrep from 68s to 33s, and debug build time also decreases from 22s to 15.5s. This was entirely unintentional but a welcome surprise.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 10 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 61f0b735..b36bac88 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -35,7 +35,6 @@ members = [ "grep", "globset", "ignore", "termcolor", "wincolor" ]
[dependencies]
atty = "0.2.2"
bytecount = "0.3.1"
-clap = "2.26"
encoding_rs = "0.7"
grep = { version = "0.1.7", path = "grep" }
ignore = { version = "0.3.1", path = "ignore" }
@@ -50,14 +49,23 @@ same-file = "1"
termcolor = { version = "0.3.3", path = "termcolor" }
globset = { version = "0.2.1", path = "globset" }
+[dependencies.clap]
+version = "2.26"
+default-features = false
+features = ["suggestions", "color"]
+
[target.'cfg(windows)'.dependencies.winapi]
version = "0.3"
features = ["std", "winnt"]
[build-dependencies]
-clap = "2.26"
lazy_static = "1"
+[build-dependencies.clap]
+version = "2.26"
+default-features = false
+features = ["suggestions", "color"]
+
[features]
avx-accel = ["bytecount/avx-accel"]
simd-accel = [