summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-02-05 19:22:44 -0500
committerAndrew Gallant <jamslam@gmail.com>2018-02-06 12:07:59 -0500
commit8cb5833ef9fd6c4c351d10a3e950339fa89adf49 (patch)
tree28310d7b592cc453371f06ead06a1d657f241038 /Cargo.toml
parent85cd3f0a6e72a1d75c37be7b8ee4677a6bcc3f3d (diff)
argv: update clap to 2.29.4
We use the new AppSettings::AllArgsOverrideSelf to permit all flags to be specified multiple times. This removes the need for our previous work-around where we would enable `multiple` for every flag and then just extract the last value when consuming clap's matches. We also add a couple regression tests that ensure repeated switches and flags work as expected.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b36bac88..c7c9dfa3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,7 +30,7 @@ name = "integration"
path = "tests/tests.rs"
[workspace]
-members = [ "grep", "globset", "ignore", "termcolor", "wincolor" ]
+members = ["grep", "globset", "ignore", "termcolor", "wincolor"]
[dependencies]
atty = "0.2.2"
@@ -50,7 +50,7 @@ termcolor = { version = "0.3.3", path = "termcolor" }
globset = { version = "0.2.1", path = "globset" }
[dependencies.clap]
-version = "2.26"
+version = "2.29.4"
default-features = false
features = ["suggestions", "color"]
@@ -62,7 +62,7 @@ features = ["std", "winnt"]
lazy_static = "1"
[build-dependencies.clap]
-version = "2.26"
+version = "2.29.4"
default-features = false
features = ["suggestions", "color"]