summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2018-07-21 20:36:32 -0400
committerAndrew Gallant <jamslam@gmail.com>2018-07-21 20:36:32 -0400
commit209a125ea25615e8fa605c844f8cbcca8c672208 (patch)
tree640f6abf39ad6cae599524bb529aa7fedd03c6c6 /Cargo.toml
parent090216cf002a579c987df76125fcdcb97478d48e (diff)
ripgrep: replace decoder with encoding_rs_io
This commit mostly moves the transcoder implementation to its own crate: https://github.com/BurntSushi/encoding_rs_io The new crate adds clear documentation and cleans up the implementation to fully implement the contract of io::Read.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c9b02d4c..8686d515 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -38,6 +38,7 @@ members = ["grep", "globset", "ignore"]
atty = "0.2.10"
bytecount = "0.3.1"
encoding_rs = "0.8"
+encoding_rs_io = "0.1"
globset = { version = "0.4.0", path = "globset" }
grep = { version = "0.1.8", path = "grep" }
ignore = { version = "0.4.0", path = "ignore" }