summaryrefslogtreecommitdiffstats
path: root/librepology/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'librepology/Cargo.toml')
-rw-r--r--librepology/Cargo.toml43
1 files changed, 27 insertions, 16 deletions
diff --git a/librepology/Cargo.toml b/librepology/Cargo.toml
index c5c2c28..7dadd2f 100644
--- a/librepology/Cargo.toml
+++ b/librepology/Cargo.toml
@@ -1,25 +1,36 @@
[package]
-name = "librepology"
-version = "0.1.0"
-authors = ["Matthias Beyer <matthias.beyer@atos.net>"]
-edition = "2018"
+name = "librepology"
+version = "0.1.0"
+authors = ["Matthias Beyer <matthias.beyer@atos.net>"]
+edition = "2018"
+description = "Library for repology.org API access"
+documentation = "https://docs.rs/librepology"
+homepage = "https://github.com/matthiasbeyer/repolocli"
+repository = "https://github.com/matthiasbeyer/repolocli"
+readme = "./README.md"
+keywords = ["api", "repology"]
+categories = ["data-structures", "api-bindings"]
+license = "MPL-2.0"
+license-file = "./LICENSE"
+
+[badges]
+maintenance = { status = "actively-developed" }
[dependencies]
-serde = "1"
-serde_derive = "1"
-serde_json = "1"
-url = "1.7"
-url_serde = "0.2"
-failure = "0.1"
-log = "0.4"
-derive_more = "0.14"
-curl = "0.4"
+serde = "1"
+serde_derive = "1"
+serde_json = "1"
+url = "1.7"
+url_serde = "0.2"
+failure = "0.1"
+log = "0.4"
+derive_more = "0.14"
+curl = "0.4"
filters = { version = "0.3", optional = true }
derive-new = { version = "0.5", optional = true }
[features]
# By default, we include the filters functionality
-default = [ "packagefilters" ]
-
-packagefilters = ["filters", "derive-new"] \ No newline at end of file
+default = [ "packagefilters" ]
+packagefilters = ["filters", "derive-new"]