summaryrefslogtreecommitdiffstats
path: root/api/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'api/setup.py')
-rw-r--r--api/setup.py40
1 files changed, 20 insertions, 20 deletions
diff --git a/api/setup.py b/api/setup.py
index 13017233..2555db4d 100644
--- a/api/setup.py
+++ b/api/setup.py
@@ -10,29 +10,29 @@ setup(
author="Dashie",
author_email="dashie@sigpipe.me",
install_requires=[
- "Flask==1.1.1",
- "SQLAlchemy==1.3.12",
- "WTForms==2.2.1",
- "WTForms-Alchemy==0.16.9",
- "SQLAlchemy-Searchable==1.1.0",
+ "Flask==1.1.2",
+ "SQLAlchemy==1.3.23",
+ "WTForms==2.3.3",
+ "WTForms-Alchemy==0.17.0",
+ "SQLAlchemy-Searchable==1.2.0",
"SQLAlchemy-Utils==0.36.1",
- "Bootstrap-Flask==1.2.0",
+ "Bootstrap-Flask==1.5.1",
"Flask-Mail==0.9.1",
- "Flask-Migrate==2.4.0",
- "Flask-Uploads==0.2.1",
- "bcrypt==3.1.7",
- "pydub==0.23.1",
- "psycopg2-binary==2.8.4",
- "mutagen==1.43.0",
- "unidecode==1.1.1",
- "Flask_Babelex==0.9.3",
- "texttable==1.6.1",
- "python-slugify==4.0.0",
- "python-magic==0.4.15",
- "redis==3.3.11",
- "celery==4.4.0",
+ "Flask-Migrate==2.7.0",
+ "Flask-Reuploaded==0.5.0",
+ "bcrypt==3.2.0",
+ "pydub==0.24.1",
+ "psycopg2-binary==2.8.6",
+ "mutagen==1.45.1",
+ "unidecode==1.2.0",
+ "Flask_Babel==2.0.0",
+ "texttable==1.6.3",
+ "python-slugify==4.0.1",
+ "python-magic==0.4.22",
+ "redis==3.5.3",
+ "celery==5.0.5",
"flask-accept==0.0.6",
],
setup_requires=["pytest-runner"],
- tests_require=["pytest==5.3.2", "pytest-cov==2.8.1", "jsonschema==3.2.0"],
+ tests_require=["pytest==6.2.2", "pytest-cov==2.11.1", "jsonschema==3.2.0", "pytest-sugar==0.9.4"],
)