summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorYour Name <brouwer@annejan.com>2015-07-30 18:34:19 +0200
committerYour Name <you@example.com>2015-07-30 18:34:19 +0200
commitd4e0e23e2a32691c8f6d4aec859e3c5d24f30b9c (patch)
tree2d2532fd8febd229dd925897a8d7452a39047ff3 /debian
parent50aadf24c4b82b98ad7192e2ae8d830939d5217b (diff)
more debian attempts
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules88
4 files changed, 9 insertions, 89 deletions
diff --git a/debian/changelog b/debian/changelog
index 02c81105..541c63e7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,6 @@
-qtpass (0.9) git; urgency=low
+qtpass (0.9) trusty; urgency=low
* Release candidate
-
- -- Anne Jan Brouwer <brouwer@annejan.com> Wed, 13 May 2015 16:51:09 +0200
-
+
-- Anne Jan Brouwer (JinX) <brouwer@annejan.com> Thu, 30 Jul 2015 16:27:11 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..ec635144
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
index a9aae4ee..714b51a2 100644
--- a/debian/control
+++ b/debian/control
@@ -1,5 +1,5 @@
Source: qtpass
-Section: utilities
+Section: utils
Priority: optional
Maintainer: Anne Jan Brouwer <brouwer@annejan.com>
Build-Depends: qt5-default, qt5-qmake
diff --git a/debian/rules b/debian/rules
index ae34380f..f2cf009e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,86 +1,6 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
+%:
+ dh $@
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
-CFLAGS = -g
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -O0
-else
-CFLAGS += -O2
-endif
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # Add here commands to compile the package.
- qmake CONFIG+=release
- make
- # --- end custom part for compiling
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- make clean || true
- # --- end custom part for cleaning up
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package
- # The DESTDIR Has To Be Exactly /usr/src/packages/BUILD/debian/<nameOfPackage>
- make install DESTDIR=/usr/src/packages/BUILD/debian/qtpass
- # --- end custom part for installing
-
-# Build architecture-independent files here.
-binary-indep: build install
- # We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
-# dh_installdebconf
- dh_installdocs
- dh_installexamples
- dh_installmenu
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
- dh_installcron
- dh_installman
- dh_installinfo
-# dh_undocumented
- dh_installchangelogs
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_makeshlibs
- dh_installdeb
-# dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_install:
+ $(MAKE) DESTDIR=$$(pwd)/debian/qtpass prefix=/usr install