summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py88
1 files changed, 43 insertions, 45 deletions
diff --git a/setup.py b/setup.py
index 775c46ef..57d791ae 100644
--- a/setup.py
+++ b/setup.py
@@ -3,24 +3,25 @@ import ast
import platform
from setuptools import setup, find_packages
-_version_re = re.compile(r'__version__\s+=\s+(.*)')
+_version_re = re.compile(r"__version__\s+=\s+(.*)")
-with open('pgcli/__init__.py', 'rb') as f:
- version = str(ast.literal_eval(_version_re.search(
- f.read().decode('utf-8')).group(1)))
+with open("pgcli/__init__.py", "rb") as f:
+ version = str(
+ ast.literal_eval(_version_re.search(f.read().decode("utf-8")).group(1))
+ )
-description = 'CLI for Postgres Database. With auto-completion and syntax highlighting.'
+description = "CLI for Postgres Database. With auto-completion and syntax highlighting."
install_requirements = [
- 'pgspecial>=1.11.5',
- 'click >= 4.1',
- 'Pygments >= 2.0', # Pygments has to be Capitalcased. WTF?
- 'prompt_toolkit>=2.0.6,<2.1.0',
- 'psycopg2 >= 2.7.4,<2.8',
- 'sqlparse >=0.3.0,<0.4',
- 'configobj >= 5.0.6',
- 'humanize >= 0.5.1',
- 'cli_helpers[styles] >= 1.2.0',
+ "pgspecial>=1.11.5",
+ "click >= 4.1",
+ "Pygments >= 2.0", # Pygments has to be Capitalcased. WTF?
+ "prompt_toolkit>=2.0.6,<2.1.0",
+ "psycopg2 >= 2.7.4,<2.8",
+ "sqlparse >=0.3.0,<0.4",
+ "configobj >= 5.0.6",
+ "humanize >= 0.5.1",
+ "cli_helpers[styles] >= 1.2.0",
]
@@ -28,45 +29,42 @@ install_requirements = [
# But this is not necessary in Windows since the password is never shown in the
# task manager. Also setproctitle is a hard dependency to install in Windows,
# so we'll only install it if we're not in Windows.
-if platform.system() != 'Windows' and not platform.system().startswith("CYGWIN"):
- install_requirements.append('setproctitle >= 1.1.9')
+if platform.system() != "Windows" and not platform.system().startswith("CYGWIN"):
+ install_requirements.append("setproctitle >= 1.1.9")
setup(
- name='pgcli',
- author='Pgcli Core Team',
- author_email='pgcli-dev@googlegroups.com',
+ name="pgcli",
+ author="Pgcli Core Team",
+ author_email="pgcli-dev@googlegroups.com",
version=version,
- license='BSD',
- url='http://pgcli.com',
+ license="BSD",
+ url="http://pgcli.com",
packages=find_packages(),
- package_data={'pgcli': ['pgclirc',
- 'packages/pgliterals/pgliterals.json']},
+ package_data={"pgcli": ["pgclirc", "packages/pgliterals/pgliterals.json"]},
description=description,
- long_description=open('README.rst').read(),
+ long_description=open("README.rst").read(),
install_requires=install_requirements,
- extras_require={
- 'keyring': ['keyring >= 12.2.0'],
- },
- entry_points='''
+ extras_require={"keyring": ["keyring >= 12.2.0"]},
+ entry_points="""
[console_scripts]
pgcli=pgcli.main:cli
- ''',
+ """,
classifiers=[
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Operating System :: Unix',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: SQL',
- 'Topic :: Database',
- 'Topic :: Database :: Front-Ends',
- 'Topic :: Software Development',
- 'Topic :: Software Development :: Libraries :: Python Modules',
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: Unix",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: SQL",
+ "Topic :: Database",
+ "Topic :: Database :: Front-Ends",
+ "Topic :: Software Development",
+ "Topic :: Software Development :: Libraries :: Python Modules",
],
)