summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJanus Troelsen <ysangkok@gmail.com>2016-08-29 20:12:49 +0200
committerGitHub <noreply@github.com>2016-08-29 20:12:49 +0200
commite88317f98bb0acdaca15f60b6d6b33d7cae1388a (patch)
tree9eac781ce62677f8703d8ca057b442d0d8d64d8c /setup.py
parent6d15d46a310b29f9c0936347693dddc7001d2ebe (diff)
do not install setproctitle on cygwin
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 48330223..94d51a8b 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ install_requirements = [
# But this is not necessary in Windows since the password is never shown in the
# task manager. Also setproctitle is a hard dependency to install in Windows,
# so we'll only install it if we're not in Windows.
-if platform.system() != 'Windows':
+if platform.system() != 'Windows' and not platform.system().startswith("CYGWIN"):
install_requirements.append('setproctitle >= 1.1.9')
setup(