summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGuewen Baconnier <guewen.baconnier@camptocamp.com>2015-01-07 09:10:18 +0100
committerGuewen Baconnier <guewen.baconnier@camptocamp.com>2015-01-07 09:10:18 +0100
commit2c57e4372802e44860b537b881cead7b832dd792 (patch)
tree2989852e8c57d12faf97d0b4914ebe131d370ff3 /setup.py
parent25425c72c84f145b265e52c79835f489ea2e02ed (diff)
click version must be >= 3.2
Because it uses click.termui.secho() with the keyword argument 'err' that has been added in click 3.2. Fixes #54
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f00f8407..723fa24d 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ setup(
description=description,
long_description=open('README.rst').read(),
install_requires=[
- 'click >= 3.0',
+ 'click >= 3.2',
'prompt_toolkit==0.25', # Need to pin this to 0.25 since APIs change quite a bit after this.
'psycopg2 >= 2.5.4',
'sqlparse >= 0.1.14',