summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAmjith Ramanujam <amjith.r@gmail.com>2015-01-06 19:44:57 -0800
committerAmjith Ramanujam <amjith.r@gmail.com>2015-01-06 19:44:57 -0800
commitd437a12a03f7afce97340c11084139c8a08bb6eb (patch)
tree0b0aa1350b9bf2a8bb4561b9f8fc5cb20b4fbfe6 /setup.py
parent8595284dcdf140644cb4e63c14a0124059f4823e (diff)
Update setup.py with specific versions for dependencies.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 761555c4..f00f8407 100644
--- a/setup.py
+++ b/setup.py
@@ -23,10 +23,11 @@ setup(
description=description,
long_description=open('README.rst').read(),
install_requires=[
- 'Click',
- 'prompt_toolkit',
+ 'click >= 3.0',
+ 'prompt_toolkit==0.25', # Need to pin this to 0.25 since APIs change quite a bit after this.
'psycopg2 >= 2.5.4',
- 'sqlparse',
+ 'sqlparse >= 0.1.14',
+ 'pygments >= 2.0'
],
entry_points='''
[console_scripts]