summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan Slenders <jonathan@slenders.be>2015-01-24 20:50:04 +0100
committerJonathan Slenders <jonathan@slenders.be>2015-01-25 11:55:50 +0100
commita622f51d038951611082b4405ffd4f937bfb86e7 (patch)
tree79c842332beda43b9abd8bd0fc80cdaf6696a5f7 /setup.py
parent10ee9326443b9c121f7ae84682c63bbe1b4a0c58 (diff)
Moving ptpython code out of the prompt-toolkit repository.
We have a separate ptpython repository now.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 0 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 4ae6d90d..2fffed7e 100644
--- a/setup.py
+++ b/setup.py
@@ -8,24 +8,12 @@ setup(
version='0.26',
license='LICENSE.txt',
url='https://github.com/jonathanslenders/python-prompt-toolkit',
-
description='Library for building powerful interactive command lines in Python',
long_description='',
packages=find_packages('.'),
install_requires = [
- 'docopt',
- 'jedi>=0.8.1',
'pygments',
'six>=1.8.0',
'wcwidth',
],
- entry_points={
- 'console_scripts': [
- 'ptpython = prompt_toolkit.contrib.entry_points.ptpython:run',
- 'ptipython = prompt_toolkit.contrib.entry_points.ptipython:run',
- ]
- },
- extras_require = {
- 'ptipython': ['ipython'] # For ptipython, we need to have IPython
- }
)