summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan Slenders <jonathan@slenders.be>2014-10-29 21:23:56 +0100
committerJonathan Slenders <jonathan@slenders.be>2014-10-29 21:23:56 +0100
commit3ad52b3e27881771e611f0f38761cfb82a08e7bf (patch)
treec0bbac8c89ff9cb2655c779fca979c42573a081f /setup.py
parent3f2aab820e45721c276fac1cf9c60e3aeacf0bce (diff)
Added IPython requirement to extra_requires in setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index aee66322..7b992a8a 100644
--- a/setup.py
+++ b/setup.py
@@ -24,5 +24,8 @@ setup(
'ptpython = prompt_toolkit.contrib.entry_points.ptpython:run',
'ptipython = prompt_toolkit.contrib.entry_points.ptipython:run',
]
+ },
+ extras_require = {
+ 'ptipython': ['ipython'] # For ptipython, we need to have IPython
}
)