summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
author赖信涛 <laixintao@users.noreply.github.com>2020-04-06 11:56:31 +0800
committerGitHub <noreply@github.com>2020-04-05 20:56:31 -0700
commitb6e2a229e5f122a9efa31666dee7965621eff031 (patch)
tree999e6c244bd8171a61771e3312fe41a89d7429f7 /setup.py
parent93c14f844ee33e4d47ae07688f0e5ca7219df7de (diff)
upgrade prompt-toolit to 3.0 (#1149)
* upgrade prompt-toolit to 3.0 fix: https://github.com/dbcli/pgcli/issues/1148 related: https://github.com/prompt-toolkit/python-prompt-toolkit/issues/886 in order to make the `behave` test pass, I have to: - extend timeout for database connection test. - extend timeout for basic command expect. - extend timeout for features/steps/crud_table.py:: see data selected. - disable cpr for features but "run the cli" * [ci] disable CPR for all behave tests. * bugfix: remove duplicated prompt expect. * [ci] delete CPR env setting. * Revert "[ci] delete CPR env setting." This reverts commit fe4d5b565e01be6237b6df646429d26eaa0c6d92. * revert the extending timeout back. * [ci] test when didn't disable CPR. * Revert "[ci] test when didn't disable CPR." This reverts commit d379b1e736dcc6623ba53fc3d4e6f095fd3e8344.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3f523c2f..b305b227 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ install_requirements = [
"pgspecial>=1.11.8",
"click >= 4.1",
"Pygments >= 2.0", # Pygments has to be Capitalcased. WTF?
- "prompt_toolkit>=2.0.6,<3.0.0",
+ "prompt_toolkit>=3.0.0,<4.0.0",
"psycopg2 >= 2.8",
"sqlparse >=0.3.0,<0.4",
"configobj >= 5.0.6",