summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEric Young <YoungEricR@JohnDeere.com>2022-09-01 10:32:36 -0500
committerEric Young <YoungEricR@JohnDeere.com>2022-09-01 10:32:36 -0500
commit79df61f674ddb1606c8445ba239eb03a769a4ad4 (patch)
treeef5aeeed22827f26c2ca2e23d9db1e4de0925a6b /setup.py
parent94df104d7d4a97b93a28ed11f667f8e16431ed58 (diff)
Small developer improvements for Windows-based devs.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 60b0d7a2..bd49221d 100644
--- a/setup.py
+++ b/setup.py
@@ -26,6 +26,11 @@ install_requirements = [
# so we'll only install it if we're not in Windows.
if platform.system() != "Windows" and not platform.system().startswith("CYGWIN"):
install_requirements.append("setproctitle >= 1.1.9")
+
+# Windows will require the binary psycopg to run pgcli
+if platform.system() == "Windows":
+ install_requirements.append("psycopg-binary >= 3.0.14")
+
setup(
name="pgcli",