summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorIrina Truong <i.chernyavska@gmail.com>2023-10-10 21:34:59 -0700
committerGitHub <noreply@github.com>2023-10-11 12:34:59 +0800
commit6332e18b48482f29aa96290face13e9b3b7277ea (patch)
tree105077b23b003c3de96dadec1a672f525dca2258 /setup.py
parentf157f3f72ee388970861c31557ba624663d1a2c1 (diff)
Drop python 3.7, add 3.12 (#1426)
* Fix deprecation. * Drop python 3.7 and add 3.12. * Bump pendulum. * Changelog. * Update gh actions. * See if things pass without this scenario. * Skip failing scenarios in 3.12.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index cfdf3e1c..254b7218 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ install_requirements = [
"psycopg >= 3.0.14",
"sqlparse >=0.3.0,<0.5",
"configobj >= 5.0.6",
- "pendulum>=2.1.0",
+ "pendulum>=3.0.0b1",
"cli_helpers[styles] >= 2.2.1",
]
@@ -51,7 +51,7 @@ setup(
"keyring": ["keyring >= 12.2.0"],
"sshtunnel": ["sshtunnel >= 0.4.0"],
},
- python_requires=">=3.7",
+ python_requires=">=3.8",
entry_points="""
[console_scripts]
pgcli=pgcli.main:cli
@@ -62,11 +62,11 @@ setup(
"Operating System :: Unix",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
"Programming Language :: SQL",
"Topic :: Database",
"Topic :: Database :: Front-Ends",