summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorIrina Truong <i.chernyavska@gmail.com>2022-06-06 11:20:48 -0700
committerGitHub <noreply@github.com>2022-06-06 11:20:48 -0700
commit18071754bc0c79a7109c5ccfdaa74ed913c343ba (patch)
treec6426b4bbdd08e1931f0f49e813df592b4135d35 /setup.py
parent372da81ec4bb6572f293c00cdd5b3b4d3c38350d (diff)
Port to psycopg3 (#1324)
* WIP. * Add some comments about porting from psycopg 2 to 3 (#1318) * WIP * Disable _set_wait_callback() * TransactionStatus. * First working query. * More pg3 changes. * test_pgexecute still fails. * Fix bytea support. * Fix json and enum unicode. * Get unit tests to pass. * Behave tests still break, WIP. * Prompt seems to be displayed fine, why don't the tests see the whitespace? * Python version. * Fix test. * Black. * Added black to dev reqs. * nbu link for donations. * Use psycopg.sql to format statement. * Special case for show help in pgbouncer. * Fix test. * Added integration test. * Install pgbouncer in ci. * Fix integration test. * Remove tmate session. * Revert commenting out python versions. * Pin pgspecial to >=2. * Changelog. Co-authored-by: Daniele Varrazzo <daniele.varrazzo@gmail.com> Co-authored-by: Amjith Ramanujam <amjith.r@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 975819b3..60b0d7a2 100644
--- a/setup.py
+++ b/setup.py
@@ -6,13 +6,13 @@ from pgcli import __version__
description = "CLI for Postgres Database. With auto-completion and syntax highlighting."
install_requirements = [
- "pgspecial>=1.13.1,<2.0.0",
+ "pgspecial>=2.0.0",
"click >= 4.1",
"Pygments>=2.0", # Pygments has to be Capitalcased. WTF?
# We still need to use pt-2 unless pt-3 released on Fedora32
# see: https://github.com/dbcli/pgcli/pull/1197
"prompt_toolkit>=2.0.6,<4.0.0",
- "psycopg2 >= 2.8",
+ "psycopg >= 3.0.14",
"sqlparse >=0.3.0,<0.5",
"configobj >= 5.0.6",
"pendulum>=2.1.0",
@@ -34,19 +34,19 @@ setup(
version=__version__,
license="BSD",
url="http://pgcli.com",
- project_urls={
- "Source": "https://github.com/dbcli/pgcli",
- },
packages=find_packages(),
package_data={"pgcli": ["pgclirc", "packages/pgliterals/pgliterals.json"]},
description=description,
long_description=open("README.rst").read(),
install_requires=install_requirements,
+ dependency_links=[
+ "http://github.com/psycopg/repo/tarball/master#egg=psycopg-3.0.10"
+ ],
extras_require={
"keyring": ["keyring >= 12.2.0"],
"sshtunnel": ["sshtunnel >= 0.4.0"],
},
- python_requires=">=3.6",
+ python_requires=">=3.7",
entry_points="""
[console_scripts]
pgcli=pgcli.main:cli
@@ -57,10 +57,10 @@ setup(
"Operating System :: Unix",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: SQL",
"Topic :: Database",
"Topic :: Database :: Front-Ends",