summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorlaixintao <laixintaoo@gmail.com>2020-09-14 11:55:44 +0800
committerGitHub <noreply@github.com>2020-09-14 11:55:44 +0800
commit7626d9a5f27a221d87f31dcb5bb8fc12024f6c58 (patch)
treecbcf8363bf3e8e57905d30f7b0426af77c958023 /setup.py
parent59ae65cbbf698d1608e7fd3d55b507f3599ac117 (diff)
parent13bd678ccd14e025406ed72490ab52f840ecffa2 (diff)
Merge pull request #1211 from dbcli/bugfix/behave
fix behave test, keep support for prompt-toolkit 2.x; lock prompt-toolkit==3.0.5 for test.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5a221d98..4e0696fd 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,9 @@ install_requirements = [
"pgspecial>=1.11.8",
"click >= 4.1",
"Pygments >= 2.0", # Pygments has to be Capitalcased. WTF?
- "prompt_toolkit>=3.0.6,<4.0.0",
+ # We still need to use pt-2 unless pt-3 released on Fedora32
+ # see: https://github.com/dbcli/pgcli/pull/1197
+ "prompt_toolkit>=2.0.6,<4.0.0",
"psycopg2 >= 2.8",
"sqlparse >=0.3.0,<0.4",
"configobj >= 5.0.6",