summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL7
1 files changed, 5 insertions, 2 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 09eb93653b..2a67ad061d 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -2,7 +2,11 @@
## Makefile.PL -- Perl MakeMaker specification
##
-$V = '0.9.2b';
+open(IN,"<../Makefile.ssl") || die "unable to open Makefile.ssl!\n";
+while(<IN>) {
+ $V=$1 if (/^VERSION=(.*)$/);
+}
+close(IN);
print "Configuring companion Perl module for OpenSSL $V\n";
use ExtUtils::MakeMaker;
@@ -18,7 +22,6 @@ WriteMakefile(
'DEFINE' => '',
'INC' => '-I../include',
'H' => ['openssl.h'],
- 'C' => ['openssl_cb.c'],
'OBJECT' =>
'OpenSSL.o ' .
'openssl_bio.o ' .