summaryrefslogtreecommitdiffstats
path: root/external/perl/Text-Template-1.56/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'external/perl/Text-Template-1.56/Makefile.PL')
-rw-r--r--external/perl/Text-Template-1.56/Makefile.PL71
1 files changed, 71 insertions, 0 deletions
diff --git a/external/perl/Text-Template-1.56/Makefile.PL b/external/perl/Text-Template-1.56/Makefile.PL
new file mode 100644
index 0000000000..15b421be1f
--- /dev/null
+++ b/external/perl/Text-Template-1.56/Makefile.PL
@@ -0,0 +1,71 @@
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.012.
+use strict;
+use warnings;
+
+use 5.008;
+
+use ExtUtils::MakeMaker;
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "Expand template text with embedded Perl",
+ "AUTHOR" => "Michael Schout <mschout\@cpan.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "Text-Template",
+ "LICENSE" => "perl",
+ "MIN_PERL_VERSION" => "5.008",
+ "NAME" => "Text::Template",
+ "PREREQ_PM" => {
+ "Carp" => 0,
+ "Encode" => 0,
+ "Exporter" => 0,
+ "base" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "File::Temp" => 0,
+ "Safe" => 0,
+ "Test::More" => 0,
+ "Test::More::UTF8" => 0,
+ "Test::Warnings" => 0,
+ "lib" => 0,
+ "utf8" => 0,
+ "vars" => 0
+ },
+ "VERSION" => "1.56",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Carp" => 0,
+ "Encode" => 0,
+ "Exporter" => 0,
+ "File::Temp" => 0,
+ "Safe" => 0,
+ "Test::More" => 0,
+ "Test::More::UTF8" => 0,
+ "Test::Warnings" => 0,
+ "base" => 0,
+ "lib" => 0,
+ "strict" => 0,
+ "utf8" => 0,
+ "vars" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);