summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorRalf S. Engelschall <rse@openssl.org>1999-03-08 11:25:49 +0000
committerRalf S. Engelschall <rse@openssl.org>1999-03-08 11:25:49 +0000
commit84107e6ca812b1325907596b6a5bfa9080a16a92 (patch)
tree6c5d1cb0ac3983d24c3478c132bdb907bf0acef5 /perl/Makefile.PL
parent9ea0e64de71d8b7c197a4abbf59f85bf9d0db9d4 (diff)
Second round of fixing the OpenSSL perl/ stuff. It now at least compiled fine
under Unix and passes some trivial tests I've now added. But the whole stuff is horribly incomplete, so a README.1ST with a disclaimer was added to make sure no one expects that this stuff really works in the OpenSSL 0.9.2 release. Additionally I've started to clean the XS sources up and fixed a few little bugs and inconsistencies in OpenSSL.{pm,xs} and openssl_bio.xs. PS: I'm still not convinces whether we should try to make this finally running or kick it out and replace it with some other module....
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL9
1 files changed, 7 insertions, 2 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 77d5af5f21..1f0c44abbf 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -2,14 +2,19 @@
## Makefile.PL -- Perl MakeMaker specification
##
+$V = '0.9.2';
+print "Configuring companion Perl module for OpenSSL $V\n";
+
use ExtUtils::MakeMaker;
WriteMakefile(
'OPTIMIZE' => '',
- 'DISTNAME' => 'OpenSSL-0.9.2',
+ 'DISTNAME' => "openssl-$V",
'NAME' => 'OpenSSL',
'VERSION_FROM' => 'OpenSSL.pm',
- 'LIBS' => ['-L.. -lssl -lcrypto'],
+ 'LIBS' => ( $^O eq 'MSWin32'
+ ? [ '-L../out32dll -lssleay32 -llibeay32' ]
+ : [ '-L.. -lssl -lcrypto' ] ),
'DEFINE' => '',
'INC' => '-I../include',
'H' => ['openssl.h'],